Axis

Axis is our new fullscreen portfolio wordpress theme. This is a premium quality theme with features on par with paid themes.The theme use WordPress 3 features like Custom post types, Custom taxonomies, Custom menus , featured thumbnails etc.  This will be a n ideal theme for professionals to exhibit their portfolio in style.

How it works?

The homepage of the theme is a fullscreen slider. In the admin panel you will have a separate section to add each slide and its title and description. You can adjust the transition effect between the slides and the slide delay. The following screencast shows how to create each slide.

 

At the Bottom right of the theme you will find a small toggler. That will pull up the thumbnail navigation of the slideshow.

The slideshow feature is Limited to the Homepage only. When you are on inner pages the site background changes. If you are on a single post page,the site background will automatically set with the featured image of that post. For any other page you will have an option to set a background image in the theme option page.

The theme also holds 2 custom page templates.

1. Blog page . You can use this page template to show your blog entries.

2. Full wide – Use this template to show a page with no sidebar

This theme will be fun to work with and it will make your site of premium quality.

 

  • Betoc

    Broken link 🙁

  • http://www.web2feel.com/downloads/Axis.zip

    This is the Link of the theme.

  • awesome theme

    • Anonymous

       Thanks.

      • Name

        what can i say! this theme is all fucked

  • Kybipix

    At the Bottom right of the theme you will find a small toggler. That will pull up the thumbnail navigation of the slideshow. 
    The toggler doesn’t work, not with firefox and not with chrome.Why?

    • Anonymous

       Can you send me your site details? I will check it.

      • Kybipix

        It’s this website: http://www.nicole-prescott.net/
        The written text is also not visible in the dark rectangle.
        Thank you very much

        • Anonymous

          It seems like a plugin conflict. Mail me your wp access details if possible to web2feel[at]gmail[dot]com

        • Kybipix

          Thanks
          One problem is solved. Posted this problem in the forum of the nextGEN Gallery.

          I like your themes very much! they look absolutely great and a lot of friends send me compliments (about your theme)!.

  • Niju Mohan

    How to set the post listing page?

  • AleOtero

    I’ve shuttershut working fine, but I can’t make Axis work.  Slides are ok, Featured images are ok, I don’t know what else I need to look for (www.aleotero.com)

  • Levent Müslim

    I’m gonna use it for my portfolio where I pulish my works. Thank you for the theme Jinson

  • 19110156

    很喜欢这里的主题

    • 601123666

      呵呵,我也喜欢这个主题,但是遇到一个问题,能不能交流下,我的QQ601123666.

  • It doesn’t work in russian 🙁

    • Max Goustarev

      =(

    • Lee

      You mean russian font dosent work? you can change fonts…

  • Marco

    I have some problems in the administration menu with the quickedit-function when I am using this theme. It seems like some scripts are not working anymore. Has anyone the same issues?

    • Betoc

      Yeap. You should use not a big images. For example 1024*768.
      When i trying to upload images more then this resolution – it doesn’t work.

  • 731

    Hello, I have been using shuttershut and now want to change to Axis. But the slide is not working with Axis.. Do you know why?

  • Betoc

    Yeap. You should use not a big images. For example 1024*768.
    When i trying to upload images more then this resolution – it doesn’t work.

  • Pablogargar

    Hi, my photos do not appaer in the slide….
    Help me please…

  • casan

    Hey my photos do not appear in the slide…. I’m work on my local server WAMP… Could you help me please? 

  • Heliaasemon

    please chek my site 

  • Heliaasemon

     http://dmpc.ir

  • Steph

    Hi There, I would like to centre the content instead of right aligned only on the pages, not the slideshow. Is this possible? Also, can you put a logo at the top left instead of the name in a font? Thanks so much I love the theme! 

    • adminqcq

      I´d like to know how to put a logo at the top feft also…. Thank you.

  • Steph

    I am loving the theme and building my webpage, but it seems that my slides aren’t working.. could you please take a look http://www.stephmccabe.net 

  • Pardus

    There is a jquery problem but i couldnt find where it is… When i activate the theme, the dashboard submenu system doesnt work, slideshow doesnt work etc… 🙁 I am using wp 3.3.2

  • Meghan

    I am curious to know if any of these issues have been resolved and if there is a common issue that I should look for.  I am also unable to get pictures to appear in the slides.  I’m really excited about the theme and would like to get it working.  The images are actually quite small, so I can rule that out, at least.

  • Arionne

    I love everything about this theme! But I can’t seem to get the slides working. Any common mistakes that I might be making? arionnealyssa.com

    • Arionne

      Correction: I can get one slide to work perfectly, but once I add any more, it stops working.

  • Charles Veiga Santos

    Hello, my name is Charles. I really can not add more than one slide on this theme, I am not an expert in PHP or JS but there really is a bug in it that does not allow to view the slides, or rather the theme just does not work.Is there any chance you fix this?Just like me many others are having the same problem, I’m using the latest version of WP 3.4 as well as in DEMO, uninstalled all the plugins, but nothing.I’m waiting.Thank you.

  • XXXXXX

    Has anyone solved any problem. Can’t get the slider working. Everything seems to be right.

    • Meghan

       Nope. I gave up on this theme.  It looks like it should be great but since I can’t get an answer on what seems to be a really common problem, I had to move on.

  • Charles Veiga Santos

    Hello, I found out where this error.
    The problem is in the title and description of the slide.
    I got the same code of the theme Shutter
      And the Axis used the slider is working again, but left without the title and description of the Slide.
    I do not know anything about PHP or JS and found nothing that could help me on the net.
    If any kind soul has the willingness to correct this small error (I believe) and go to “us” I will be eternally grateful.

  • shinyangel.my

    just get the slide thingy done, my solution is go to the Axis Option under Theme, then click on the “save changes” button, may be some file have to create first. my site = http://shinyangel.my

  • Charles Veiga Santos

    Simply put categories. I was creating the slides but not putting them category. Yes it is a bug, but insurmountable, just put a category on the slide and it worked perfectly.

  • Also make sure the post content in the slide is strictly plain text. That has worked for me.

  • Mauro

    Hi, I try and try, but I can not. Firefox opens site without error, but in Internet Explorer 8 and 9 opens badly (without slider and site has a margin from the top). I checked the styles and js files. I do not know what is wrong. Anyone knows how to fix it? http://www.elisalonpieknosci.pl/

    • Marcin Lemanczyk

      Mauro jak udało Ci się uruchomić pokaz slajdów na stronce. Ja wciąż próbuję i nie daję rady.

      • Mauro

        Czy nie działa nadal jak wyrzucisz teksty i zrobisz slajdy z samymi obrazkami? Bo ja miałem problem ze spacjami na końcu fraz i niekiedy również ze znakami diakrytycznymi – po prostu się nie chciał ładować slajd po zapisaniu. Pomogła tak naprawdę korekta tekstów by nie było spacji na końcu. Ze znakami diakrytycznymi nie wiem do końca jak jest. Metodą prób i błędów dobrałem tekst by to działało.

      • alicjusia

        hej:) czy wiecie jak usunac z bloga prawa kolumne ze “sponsorami” i jak wysrodkowac Pagesy?:)

    • Hi Mauro, I see you are one of the lucky ones who found the way to make it work…. how you did it?
      could you explain what you did to make the slide show work?
      Maybe not in greek pls 😉

  • I’ve been working on this theme for 2 days now.
    While I’m a noob at website development with WordPress, I know my way around in PHP, javascript(JQuery), HTML4/5 and CSS2/3.
    The help from the developer of the theme doesn’t seem to be too eager.
    I’m testing on a local server and found out that the GD library of my PHP server was not enable by default.
    I was having the same issue as others, the slide didn’T work. Once this library enabled in the PHP server, the slides are working now.
    But (you were seeing it coming didn’t you) there is a but, I don’t have the progress bar going nor the button to enable the thumbnails at the bottom of the screen and the slide description is just a blank white rectangle.
    I am suspecting it has to do with how the HOME screen is declared but I just can’t figure it out.
    Some help from the developer would be a nice touch since this seems to be a related problem with what a lot of people are experiencing.
    I am pretty sure there is probably a very simple solution to this.
    Any help would be very much appreciated.

  • LanManT

    Update: shinyangel.my solution below worked.

    Thanks shinyangel.my

    delete > Excellent theme but it does not work with those simple instructions, and yes i have php5.3 and gd enabled and 755 set for the axis/cache folder. too bad < delete

  • Gary Stevenson

    I’m having pretty much the same problem as everybody else – I just can’t get the slider to work.. It’s a shame because this theme looks awesome! I have tried adding a category, clicking save changes in the theme option, checking that the access is 755 and removing all plugins.. Anybody able to help?

  • Greg

    Congratulations for the theme, i have a question if possible…
    That post featured the image of you do not want in the background but only in miniature, having as background the image of default?

  • Lee

    First of all, your theme is fucking great! Thans for sharing!

    When I find function that thumbnail navigation will be open on the home page, by deafult ?

    Regards
    Lee

    • Lukemunnell.com

      Has anyone found a way to do thiss?

  • Petr

    Javascript is broken by multi line content (no continuation line in parameter slides/desc). Use apply_filter() and insert at each EOL backslash as JS continuation character.
    >>header.php<<
    ID, ‘wtf_slide’, true);
    $nimg = get_the_title();
    $cimg = get_the_content();
    $cimg = apply_filters(‘the_content’, $cimg);
    $cimg = str_replace(“]]>”, “]]>”, $cimg);
    $cimg = str_replace(“n”, “\n”, $cimg);
    if ($i>0): echo ‘,’; else: echo ”; endif; //For IE sake add a coma BEFORE every image offsetting the first one.
    echo “{image : ‘”.$simg.”‘,title : ‘”.$nimg.”‘,desc : ‘”.$cimg.”‘}”;
    $i++;
    endwhile;
    wp_reset_query(); ?>

    • Thanks for the share Petr. Your solution works. I’ve noticed that even after your post, many people are still looking for answers. Will re-post your solution at the end of the thread.

  • Jean Carlos

    I’m have one problem with hin. When I activate the theme do varius erros:

    ‘Slide Image’, ‘desc’ => ‘Copy paste the uploaded image url here.’, ‘id’ => $prefix.’slide’, ‘type’ => ‘text’ ), ); // enqueue scripts and styles, but only if is_admin if(is_admin()) { wp_enqueue_script(‘jquery-ui-datepicker’); wp_enqueue_script(‘jquery-ui-slider’); wp_enqueue_script(‘custom-js’, get_template_directory_uri().’/js/custom-js.js’); wp_enqueue_style(‘jquery-ui-custom’, get_template_directory_uri().’/css/jquery-ui-custom.css’); } // add some custom js to the head of the page add_action(‘admin_head’,’add_custom_scripts’); function add_custom_scripts() { global $custom_meta_fields, $post; $output = ”; echo $output; } // The Callback function show_custom_meta_box() { global $custom_meta_fields, $post; // Use nonce for verification echo ”; // Begin the field table and loop echo ”; foreach ($custom_meta_fields as $field) { // get value of this field if it exists for this post $meta = get_post_meta($post->ID, $field[‘id’], true); // begin a table row with echo ”; } // end foreach echo ”.$field[‘label’].”; switch($field[‘type’]) { // text case ‘text’: echo ‘
    ‘.$field[‘desc’].”; break; // textarea case ‘textarea’: echo ‘
    ‘.$field[‘desc’].”; break; // checkbox case ‘checkbox’: echo ‘ ‘.$field[‘desc’].”; break; // select case ‘select’: echo ”; foreach ($field[‘options’] as $option) { echo ”.$option[‘label’].”; } echo ‘
    ‘.$field[‘desc’].”; break; // radio case ‘radio’: foreach ( $field[‘options’] as $option ) { echo ‘ ‘.$option[‘label’].’
    ‘; } echo ”.$field[‘desc’].”; break; // checkbox_group case ‘checkbox_group’: foreach ($field[‘options’] as $option) { echo ‘ ‘.$option[‘label’].’
    ‘; } echo ”.$field[‘desc’].”; break; // tax_select case ‘tax_select’: echo ‘ Select One’; // Select One $terms = get_terms($field[‘id’], ‘get=all’); $selected = wp_get_object_terms($post->ID, $field[‘id’]); foreach ($terms as $term) { if (!empty($selected) && !strcmp($term->slug, $selected[0]->slug)) echo ”.$term->name.”; else echo ”.$term->name.”; } $taxonomy = get_taxonomy($field[‘id’]); echo ‘
    Manage ‘.$taxonomy->label.”; break; // post_list case ‘post_list’: $items = get_posts( array ( ‘post_type’ => $field[‘post_type’], ‘posts_per_page’ => -1 )); echo ‘ Select One’; // Select One foreach($items as $item) { echo ‘ID ? ‘ selected=”selected”‘ : ”,’>’.$item->post_type.’: ‘.$item->post_title.”; } // end foreach echo ‘
    ‘.$field[‘desc’].”; break; // date case ‘date’: echo ‘
    ‘.$field[‘desc’].”; break; // slider case ‘slider’: $value = $meta != ” ? $meta : ‘0’; echo ‘
    ‘.$field[‘desc’].”; break; // image case ‘image’: $image = get_template_directory_uri().’/images/image.png’; echo ”; if ($meta) { $image = wp_get_attachment_image_src($meta, ‘medium’); $image = $image[0]; } echo ‘
    Remove Image
    ‘.$field[‘desc’].”; break; // repeatable case ‘repeatable’: echo ‘+’; $i = 0; if ($meta) { foreach($meta as $row) { echo ‘||| -‘; $i++; } } else { echo ‘||| -‘; } echo ”.$field[‘desc’].”; break; } //end switch echo ”; // end table } /* function remove_taxonomy_boxes() { remove_meta_box(‘categorydiv’, ‘post’, ‘side’); } add_action( ‘admin_menu’ , ‘remove_taxonomy_boxes’ ); */ // Save the Data function save_custom_meta($post_id) { global $custom_meta_fields; // verify nonce if (!wp_verify_nonce($_POST[‘custom_meta_box_nonce’], basename(__FILE__))) return $post_id; // check autosave if (defined(‘DOING_AUTOSAVE’) && DOING_AUTOSAVE) return $post_id; // check permissions if (‘page’ == $_POST[‘post_type’]) { if (!current_user_can(‘edit_page’, $post_id)) return $post_id; } elseif (!current_user_can(‘edit_post’, $post_id)) { return $post_id; } // loop through fields and save the data foreach ($custom_meta_fields as $field) { if($field[‘type’] == ‘tax_select’) continue; $old = get_post_meta($post_id, $field[‘id’], true); $new = $_POST[$field[‘id’]]; if ($new && $new != $old) { update_post_meta($post_id, $field[‘id’], $new); } elseif (” == $new && $old) { delete_post_meta($post_id, $field[‘id’], $old); } } // enf foreach // save taxonomies $post = get_post($post_id); $category = $_POST[‘category’]; wp_set_object_terms( $post_id, $category, ‘category’ ); } add_action(‘save_post’, ‘save_custom_meta’); ?>
    Warning: Cannot modify header information – headers already sent by (output started at F:Othersweb_developmentxampphtdocswordpresswp-contentthemesAxislibadd_meta_box.php:246) inF:Othersweb_developmentxampphtdocswordpresswp-includesoption.php on line 563

    Warning: Cannot modify header information – headers already sent by (output started at F:Othersweb_developmentxampphtdocswordpresswp-contentthemesAxislibadd_meta_box.php:246) inF:Othersweb_developmentxampphtdocswordpresswp-includesoption.php on line 564

    Can you help me?

    • Sauce

      Hello sir. I had the same problem. In the file add_meta_box.php (F:Othersweb_developmentxampphtdocswordpresswp-contentthemesAxislibadd_meta_box.php), at the first line, I replace “<?" with "<?php". It seems to be working now.

      • sauce

        “< ? " with "< ? php " (remove the spaces)

        • Edgar Andara

          Thanks U so much! your tip saved my life!!!

  • sappy

    hi please can anyone help me to solve this

    • Salman Alfa

      Go to Axis/lib/add_meta_box.php
      edit file on line 1 from “<?" to "<?php"

  • Didier

    No me funciona el slide principal en godaddy php5.2

  • Didier

    It doesnt work http://inmobiliariadijasa.com/losrobles/

    PHP Version 5.2.17
    wordpress 4.2

    Zend Memory Manager enabled

  • SABOOR

    Hi
    how r u

    this theme not work…!

  • thomas

    is there a possibilty to influence the sliding? I would like to switch off automatic sliding, so users have the chance to read the captures, and rather click on the arrows or thumbnails to slide… maybe I also just do not see where I change it?! 🙂

  • zupperman

    Hi
    How to use Axis Fullwide ?

  • FoVITIS

    Same Problem like Shuttershot … Comments are not possible.. thats soo stupid 🙁

  • FoVITIS

    Broken Image at Reply functions.. even in the Online Demo! ..

    timthumb.php?src=&h=250&w=620&zc=1

    src= -…. ? no source… no image… = no image shows up… why is there no image linked?

  • OSP

    i want to place the “full wide” page & the “blog page” in the center of the screen (like suttershot). please anybody can help me.

    • Mauro

      Try to change in the style.css #content and #full-content

  • FoVITIS

    WTF… Maximum 10 Slides allowed?… really?… dammed…

    • Pepito

      Any idea how to correct this?

  • FoVITIS

    Ups… a mistake.. if you write a longer text in the slide image show field… the images dont appear… not goot…but so i know it now i gan write shorter text… not perfect.

  • FoVITIS

    Ups… a mistake.. if you write a longer text in the slide image show field… the images dont appear… not goot…but so i know it now i gan write shorter text… not perfect.

  • Javascript is broken by multi line content (no continuation line in parameter slides/desc). Use apply_filter() and insert at each EOL backslash as JS continuation character.
    >>header.php<“, “]]>”, $cimg);
    $cimg = str_replace(“n”, “\n”, $cimg);
    if ($i>0): echo ‘,’; else: echo ”; endif; //For IE sake add a coma BEFORE every image offsetting the first one.
    echo “{image : ‘”.$simg.”‘,title : ‘”.$nimg.”‘,desc : ‘”.$cimg.”‘}”;
    $i++;
    endwhile;
    wp_reset_query(); ?>

  • DIYpc吧

    老大,你不是中国的啊??
    http://www.diypc8.com

  • Marcel de Korte

    Great theme. Works perfect 🙂