Axis

Axis is our new fullscreen portfolio wordpress theme. This is a premium quality theme with features on par with paid themes.The theme use WordPress 3 features like Custom post types, Custom taxonomies, Custom menus , featured thumbnails etc.  This will be a n ideal theme for professionals to exhibit their portfolio in style.

How it works?

The homepage of the theme is a fullscreen slider. In the admin panel you will have a separate section to add each slide and its title and description. You can adjust the transition effect between the slides and the slide delay. The following screencast shows how to create each slide.

 

At the Bottom right of the theme you will find a small toggler. That will pull up the thumbnail navigation of the slideshow.

The slideshow feature is Limited to the Homepage only. When you are on inner pages the site background changes. If you are on a single post page,the site background will automatically set with the featured image of that post. For any other page you will have an option to set a background image in the theme option page.

The theme also holds 2 custom page templates.

1. Blog page . You can use this page template to show your blog entries.

2. Full wide – Use this template to show a page with no sidebar

This theme will be fun to work with and it will make your site of premium quality.

 

  • vancityandy

    This theme was working great, until I changed some text in one the slides, and then it just ceased to work! It went from great, to …..well, not great at all! The screen is now just black.

  • Chris Leonard

    Great theme! Does anyone know how to change the color of the red progress bar at the top of the slideshow? I couldn’t find it in the styles.css or slides.php. Thank you for any suggestions!

  • Chris Leonard

    Does anyone know where in the code to change the color of the progress bar above the slideshow? Thank you for any suggestions!

    • jinsona

      You will find the css for the progress bar in the super sized.shutter.css file on line 180. You can either change the background image or remove the background image property and use the color code to change the progress bar color.

      • Chris Leonard

        Found it, thank you. I thought it was code and not an image. One more thing, if you don’t mind…where is the code/section to replace the text in the top left with an image?

        • Chris Leonard

          Found that too…

        • About replacing text on the top whith image…
          can you help me, where did you find it?

  • Olivier

    doesn’t seems to work with wordpress 3.5 because they said that i should be in wordpress 3.0 or higher

  • It’s not working for 3.5 wordpress

  • Anna

    Hello, thanks for the great theme…could you please help with getting it to work?

    I am using WordPress 3.5.1, followed your video (which has no sound btw) and the slide show for the front page does not work.

    I see others have the same issue, and hope that you will be providing an answer to this question soon.

    Thank you

    • minifigguy

      Are you uploading the photos to the Slides tab or the Posts tab?

  • Anna

    Spent hours tweaking this thing and finally got the slideshow to work. I installed wp-supersize plugin & activated it, then added a couple test slides. Go to Appearance>Themes and at the top next to the active Axis theme click Customize to view a preview of the live theme.

    In the Customize section look under the Static Front Page tab. I had selected the Static Page option and selected the proper pages but it did not work. Then, for the heck of it, I tried selecting Your Recent Posts rather than static page and it all worked! (If this does not fix the problem, make sure that Settings>Reading>Front Page Displays is set to Your Recent Posts.)

    The blog page does in fact show up in the right place, and all formatting was good. However, that is not how this site is setup. The site does in fact have a static front page and a specified blog page, but using those selections caused the slideshow not to work.

    There must be an issue in the code somewhere that is causing this error, but I am not sifting through all of it to figure this out. I’m just happy I got it to work, and the site looks great!

    I also did some minor changes to accommodate the clients existing content. I widened the post container (in Stylesheet.css look for #casing, I increased to 1200, and #content which I increased to 870), changed the sidebar text banner color (look for h3.sidetitl and change background color hexcode), and changed the link colors.

    The progress bar still needs to be changed to a different color, but in the supersize.shutter.css file (which can be found by clicking the plugin’s Edit link on the installed plugin page!) it appears to be pointing to an image, I could not find a color hex code to change. If anyone knows how to change this please post the answer!

    I would also like to eliminate the caption box that is displayed over the slideshow images. If anyone knows how to do this please post the answer!

    I hope this helps!

    • Julian

      I would also like to eliminate the caption box that is displayed over the slideshow images.
      how can we do ?

      • Anna

        Still trying to figure out how to eliminate that caption box on the slideshow…if anyone knows please post the answer! (hello, developer??)

      • Anna

        I found it! I have successfully removed the caption & black box from the front page slideshow.

        Go to Appearance>Editor>select the Main Index Template to open in the editor box.

        Remove the following block of code:

        No applause, just throw money.

        https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=ZE8GEZUQGLQZ8

        • Dorien

          THANK YOUUUUUUUU!!!!!

    • kaye

      I accessed the FTP client and went to /wp-content/themes/Axis/img then I edited the image progress-bar.png in photoshop I just changed the color then saved it back. After refreshing the site, it changed color. But I cannot change the button on the carousel, help

  • muzzol mussol

    do you plan to upgrade this theme to make it work with 3.5.* ?

  • muzzol mussol

    I’ve found the source problem!!!!

    If description field has any enter (carriage return) then slides are not shown.

    seems to be a bug introduced with lastest versions of WP.

    maybe someone with better knowledge on php than me can take a look at that.

    EDIT: is definitly something abouth charset. I’ve tried with translated characters: http://www.ascii.cl/htmlcodes.htm
    and it works. maybe this theme is forcing some charset when it shouldnt.

  • Prince Oliver

    Hello guys, it doesnt look liek working with the latest wp version 3.5.1 does it? Many Thanks!

  • EVERYBODY, ATTENTION PLEASE! JUST GO TO THE AXIS OPTIONS PAGE AND CLICK THE “SAVE CHANGES” BUTTON. THAT’S ALL.

  • Gustavo

    Hi Guys… THANKS FOR DE THEME.. IS PERFECT I LOVEIT… I HAVE 2 QUESTIONS (SORRY MY ENGLISH)

    I WANT TO STAY MORE TIME IN A SLIDE, FOR MY WORK IS TO FAST. CAN I CHANGE IT TIME? Have an option but i think is the transition time (the time of change betwen slides)

    MMMMM CAN I PUT A BOTON TO STOP THE INTERVAL AND START AGAIN? (Where is the “Set Interval?” if the people want to see a photo without the tumbs.

    • Dink

      PLEASE REFRAIN FROM USING CAPS SO MUCH

      For anyone still interested in setting the interval; the property for this is defined in the header.php file and is called : “slide_interval”

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • Jam_3

    can I re=locate the Slide Caption to bottom-left of the image? if so, then how-to?

  • nandin

    thanks for great theme

  • BB

    Is there a way to change how long it stays on each slide?

  • ebaiden

    AAAAAAAAAAARRRRRHHH!!!! I FOUND THE PROBLEM!!!!!! GO TO AXIS OPTIONS AND CLICK SAVE!!!!! THANK YOU TO OMER!

  • Indy-h

    For tweaking all the slider options go to header.php, find $.supersized({ After that string you find all the options of the slider except for speed and the effect. These are found in the WordPress Admin under Design –> Themes –> Axis Options. Hope this is helpfull for some of you!

  • Indy-h

    For tweaking all the slider options go to header.php, find $.supersized({ After that string you find all the options of the slider except for speed and the effect. These are found in the WordPress Admin under Design –> Themes –> Axis Options. Hope this is helpfull for some of you!

  • Sjoerd

    What is the advised size/resolution for images in the slider?

  • Clode

    Hi, I’ve download your theme and I think it’s amazing but, unfortunatelly, I can’t put the immages that I want, into the home page. I’ve followed your video tutorial, but the first and the second images that I insert in, are not displayed correctly (please find attached the screenshot): the default image is the first one, while my image is only the strip below it. The third and the fourth images, don’t have the same problem.

    Please, can anyone help me? I’ve spent a lot of weeks, trying to find a solution, but nothing!

    Thank you everyone for the attention!
    Peace,
    Claudia

  • kofi

    HOw do you inset your different blog pages on the homepage?

  • cynthia

    My slide works fine for test server in another domain but it does not work for this one http://www.volta-studio.com. I do exactly the same steps as test server. Can anybody help, please?

    • cynthia

      JUST GO TO THE AXIS OPTIONS PAGE AND CLICK THE “SAVE CHANGES” BUTTON. THAT’S ALL. Then the slide works.

      • RamiroP

        Cynthia, how did you put the logo there? And the ablum gallery is a plugin? Thxs in advance

  • Matevž Mrak

    Cynthia how did you make slides to change like that. And how did you make the timer line white? Thank you for answers 🙂

    • cynthia

      Access to Axis folder via ftp. Inside Axis folder > img folder > progress-bar.png. Download this image, change the color and put it back to the same folder.

  • Matevž Mrak

    Thank you for answer. I have another question how to make that squre smaller for 50%.

    Image:

    http://shrani.si/f/1G/111/1ZygciII/cut.png

    • Zihni Özgür Balıkoğlu

      Hi Matevz Mrak,

      In order change the size of that square, you should go to styles.css in the Appearance/Edit section and find the below code;

      /* BELOW HEADER */

      #casing {

      width: 1000px;

      padding: 0px 0px 0px 0px;

      margin-top:80px;

      margin-bottom:50px;

      }

      Just change the width size and you are ready to go… I made 500px it looks good.

      • Matevž Mrak

        thank you ! 🙂

  • RamiroP

    Cynthia, how did you put the logo there? And the ablum gallery is a plugin? Thxs in advance

  • SB

    SLIDER NOT WORKING – FIXED

    My slides in the description had carridge returns (i.e. pressing enter for new line). removed all carridge returns, and sliders work now. Im using WP 3.6

    • gu

      how could u remove all carridge returns?

  • magixmarbella

    I can´t get the slides to work!? Any ideas….. Do I need to use a specific image size!?
    I followed the video instruction, but still no luck…. Please help!!!

  • brian ball

    Can you make private gallerys with a user name and password for customer photo shoots ?

  • Heleen

    Hi there. I’m having trouble getting the ‘featured image’ to show as background on the pages of http://www.a-tria.nl. Any ideas?

  • Seahawksean

    I’m having a issues trying to create a child theme for Axis. I’ve created dozen of child themes before without issues. Not sure why this isn’t working.

    File Structures:
    wp-content/themes/axis/style.css
    wp-content/themes/axis-child/style.css

    Child style.css

    /*
    Theme: Axis Child
    Template: axis
    */

    @import url(../axis/style.css); (and also tried @import url(“../axis/style.css”); )

    I have no problem loading the parent theme. It’s there in Appearance > Themes, but the child theme is broken and I’m getting the message:

    “The following themes are installed but incomplete. Themes must have a stylesheet and a template.

    Name
    Description

    axis-child
    Stylesheet is missing.”

    i’ve also added a copy of index.php in wp-content/themes/axis-child/.

    Is this theme not child-theme compatible? Has anyone else had an issue creating a child theme for Axis?

    Thank you in advance for any advice you might be able to offer.

  • Michel

    Hi.

    Is there any option that we can use the “slider” function manually with the buttons which are shown on the right and left of the page. So in general, could we switch off the automatically sliding function.

    Best,
    Michel

  • Matevž Mrak

    Slider and background photo stopped working with WordPress 3.8? How to solve that problem?

    • Suatta

      did you resolve?

      • Matevž Mrak

        No. Backgrounds and slides still not working…

        • Sébastien Panouille

          any new for the home page slide show?

        • Matevž Mrak

          I installed new wordpress 8.1.1 and a fresh copy of Axis and set new database. It was working for a while, but slides and background stopped working in a week or so. I cant find reason why…….

          Website: http://marcic.si/

  • Ed lomax

    How do I make the thumbnails show all of the time? Any ideas? Thanks!

    • Lukemunnell.com

      Has anyone found a way to do this?

  • Sébastien Panouille

    the home page slide show is not working….
    any update soon?

  • How can I replace text on the left side of header with an image? Thanks!